Jump to content





Photo

Something's not right...


  • Please log in to reply
45 replies to this topic

#1 srm86

srm86
  • PipPipPipPipPipPipPipPipPipPipPipPip
  • Admin
  • SixtyGig Admin

  • 1,557 posts
  • LocationTexas

Posted 08 August 2015 - 10:14 PM

Here's a master thread for when something is just not quite right on SG7. It is also a general "to do" list. I'm sure there's lots of little quirks and things that we'll find as we continue playing that aren't quite like they used to be. Post it here so I can look into it and fix it!

 

In progress:

Update website info about newbies and stuff

Test Prism and ensure it is working/stable [not connecting to DB?]

Give everybody /pm permission.

 

Fixed:

Chat formatting fixed - group colors now apply in-game chat

AFK command active - we can be afk!

3-wide custom gates are live - wilds, nether and end are set up on main map with 3-wide portals

Every rank now has /afk permissions and will auto afk after a certain period of inactivity

Gates can be 2- and 3- blocks wide

Set up Main Map portals

Move basement portals back a few blocks. Dirt portals are laid where they should be.

CoreProtect issue - Database busy. Please try again later. when using /co inspect -- This has been remedied by switching to Prism.

Dynmap - show actual size of map rather than 7500 in each direction.
Disable cave layer on DynMap

Fix Dynmap world list so that worlds display in correct order and hidden worlds are not shown

Dynmap markers - dynmap markers are now working on the live map

Dynmap - sign text will only show on hover (before it showed always)
Correct Rootbrew's rank
Some death messages are not displaying colors correctly
Adjust member ranks for long-time members/promotions
Adjust Seasoned color on forum and in-game to make it a lighter blue so that it's easier to read on forum/in-game.
Mobs pushed through portals disappear
Add scrollback for dynmap
 

 

Unable to fix/replicate:

Dynmap - update time too slow. ----> Testing alone in the evening, Dynmap is taking about 15 seconds to update. This does not seem to be a problem at this time.


  • 0


#2 Blue_Dragon360

Blue_Dragon360
  • PipPipPipPipPipPipPipPipPipPip
  • Seasoned
  • Stone Pickaxe

  • 1,028 posts
  • LocationValhalla
  • Nationality:American

Posted 08 August 2015 - 10:26 PM

Slightly off topic, but could we discuss removing the cave layer from the dynmap? While it's useful, it feels slightly cheaty. I'd like to hear other opinions, though! :)

As for portals, does Stargate manage the multiple worlds, or just the method of linking them? Either way, we may want to look into Multiverse Portals instead, as it looks like the methods of portal shaping are much simpler. I'm not sure if it would transfer well, though.
  • 0
There used to be something here..


#3 srm86

srm86
  • PipPipPipPipPipPipPipPipPipPipPipPip
  • Admin
  • SixtyGig Admin

  • 1,557 posts
  • LocationTexas

Posted 08 August 2015 - 10:38 PM

Not off-topic, as that was something I was going to look at with the DynMap stuff. So no opinions necessary. It's going to go, just as soon as I start digging into DynMap config.

 

As far as the portals, Zeo and I were working on those after you logged this evening. 3-wide portals are set up and there should be a way to set up 2-wide portals to be used as well, but I'm too tired/brain dead to deal with it right now. Portals are live and I can set up 2-wide and 3-wide ones later. For now they can only be 3-wide though.

 

Oh, and to answer your question: Stargate manages the method of linking them. Multiverse manages the multiple worlds. If we have any issues with Stargate, I may switch to Multiverse Portals but if I can get it set up correctly we'll stick with what we've got.


  • 0


#4 Blue_Dragon360

Blue_Dragon360
  • PipPipPipPipPipPipPipPipPipPip
  • Seasoned
  • Stone Pickaxe

  • 1,028 posts
  • LocationValhalla
  • Nationality:American

Posted 08 August 2015 - 11:00 PM

Sounds like a plan! Good luck with the portals. :)
  • 0
There used to be something here..


#5 B01E

B01E
  • Pip
  • Established
  • Log

  • 122 posts
  • LocationBorup, Sj√¶lland, Denmark, Earth, Milkyway
  • Nationality:Danish

Posted 09 August 2015 - 11:57 AM

I have a black uneven area on Wilds Dynmap 2D from 0/65/619 to about 900/65/850 that is black. Did something not finish rendering, or is it something else...? It's not on the 3D map.

 

And also - The "/AFK" and "/afk" command is not allowed (for me).


  • 0

_____________________________________

Be who you are, and say what you feel, because those who mind don't matter, and those who matter don't mind.



#6 srm86

srm86
  • PipPipPipPipPipPipPipPipPipPipPipPip
  • Admin
  • SixtyGig Admin

  • 1,557 posts
  • LocationTexas

Posted 09 August 2015 - 09:23 PM

/AFK commands are now live and work for each rank. I've added the Dynmap issue to the in progress list. It's so strange. I thought if I went out there it would force render, but it's still not.


  • 0


#7 Likliksnek

Likliksnek
  • PipPip
  • Established
  • Plank

  • 252 posts
  • LocationHamburg, Germany
  • Nationality:German

Posted 09 August 2015 - 10:44 PM

Regarding the dynmap markers - would it be possible to only see the markers and not their text on the map? As in, only show text when hovering over, or clicking them? I can imagine it will get very crowded this way very quickly otherwise. :)

 

cheers

Lik


  • 0


#8 Blue_Dragon360

Blue_Dragon360
  • PipPipPipPipPipPipPipPipPipPip
  • Seasoned
  • Stone Pickaxe

  • 1,028 posts
  • LocationValhalla
  • Nationality:American

Posted 09 August 2015 - 11:03 PM

Regarding the dynmap markers - would it be possible to only see the markers and not their text on the map? As in, only show text when hovering over, or clicking them? I can imagine it will get very crowded this way very quickly otherwise. :)

 

cheers

Lik

Was actually thinking this myself!
 

If it's not a setting in the config files, you might be able to edit the CSS.


  • 0
There used to be something here..


#9 Blue_Dragon360

Blue_Dragon360
  • PipPipPipPipPipPipPipPipPipPip
  • Seasoned
  • Stone Pickaxe

  • 1,028 posts
  • LocationValhalla
  • Nationality:American

Posted 10 August 2015 - 02:47 PM

Is it just me, or has the 3D view on Dynmap stopped updating? None of the builds (at least on the main map, not sure about wilds) have changed within the past couple days for me, including areas I am sure have been modified. The 2D map seems to be working fine, though...

Edit: seems to be updated now. Is it a slow update period?
  • 0
There used to be something here..


#10 simonparnell

simonparnell
  • PipPipPipPipPipPip
  • Seasoned
  • Coal

  • 642 posts
  • LocationUK
  • Nationality:British

Posted 11 August 2015 - 01:11 PM

Would I be correct in thinking boats breaking when you even so much as look at them is a MC coding problem not anything to do with 60gig?


  • 0
Posted Image


#11 Blue_Dragon360

Blue_Dragon360
  • PipPipPipPipPipPipPipPipPipPip
  • Seasoned
  • Stone Pickaxe

  • 1,028 posts
  • LocationValhalla
  • Nationality:American

Posted 11 August 2015 - 01:54 PM

Would I be correct in thinking boats breaking when you even so much as look at them is a MC coding problem not anything to do with 60gig?


Yeah, that's minecraft. We can always hope... :/

About the zombie pigmen: if it were for all nether portals, that might break gold farms. Something to consider.
  • 0
There used to be something here..


#12 srm86

srm86
  • PipPipPipPipPipPipPipPipPipPipPipPip
  • Admin
  • SixtyGig Admin

  • 1,557 posts
  • LocationTexas

Posted 11 August 2015 - 04:15 PM

 

Regarding the dynmap markers - would it be possible to only see the markers and not their text on the map? As in, only show text when hovering over, or clicking them? I can imagine it will get very crowded this way very quickly otherwise. :)

 

cheers

Lik

Was actually thinking this myself!
 

If it's not a setting in the config files, you might be able to edit the CSS.

 

Didn't see this earlier. Sorry. :) Have added it to my in progress. I will look into it. If it's possible, I'll take care of it.

 

 

Is it just me, or has the 3D view on Dynmap stopped updating? None of the builds (at least on the main map, not sure about wilds) have changed within the past couple days for me, including areas I am sure have been modified. The 2D map seems to be working fine, though...

Edit: seems to be updated now. Is it a slow update period?

 

 

It might be. I'll look into it and see if I can adjust it.

 

 

 

Would I be correct in thinking boats breaking when you even so much as look at them is a MC coding problem not anything to do with 60gig?


Yeah, that's minecraft. We can always hope... :/

About the zombie pigmen: if it were for all nether portals, that might break gold farms. Something to consider.

 

 

How are they incorporated into gold farms? I don't recall if we've ever had any zombie pigmen grinder gold farm things on SixtyGig?


  • 0


#13 Blue_Dragon360

Blue_Dragon360
  • PipPipPipPipPipPipPipPipPipPip
  • Seasoned
  • Stone Pickaxe

  • 1,028 posts
  • LocationValhalla
  • Nationality:American

Posted 11 August 2015 - 07:16 PM

How are they incorporated into gold farms? I don't recall if we've ever had any zombie pigmen grinder gold farm things on SixtyGig?

Large portals have a higher chance of spawning pigmen, so they can be very obsidian efficient. There have been a few in the past on SG... I know there was at least 1 on SG6, but the guy who built it went inactive really quickly. None have been very high profile.


  • 0
There used to be something here..


#14 srm86

srm86
  • PipPipPipPipPipPipPipPipPipPipPipPip
  • Admin
  • SixtyGig Admin

  • 1,557 posts
  • LocationTexas

Posted 12 August 2015 - 08:27 PM

 

How are they incorporated into gold farms? I don't recall if we've ever had any zombie pigmen grinder gold farm things on SixtyGig?

Large portals have a higher chance of spawning pigmen, so they can be very obsidian efficient. There have been a few in the past on SG... I know there was at least 1 on SG6, but the guy who built it went inactive really quickly. None have been very high profile.

 

Alright. Well, in that case I won't try to disable pigmen from spawning from them. If it's not a bother for anybody else, that is. I just remember going from SG_Wilds to SG_Main a week or two ago and there was just an absolute mess of them and that bugged me!


  • 0


#15 Blue_Dragon360

Blue_Dragon360
  • PipPipPipPipPipPipPipPipPipPip
  • Seasoned
  • Stone Pickaxe

  • 1,028 posts
  • LocationValhalla
  • Nationality:American

Posted 13 August 2015 - 11:43 AM

 

Alright. Well, in that case I won't try to disable pigmen from spawning from them. If it's not a bother for anybody else, that is. I just remember going from SG_Wilds to SG_Main a week or two ago and there was just an absolute mess of them and that bugged me!

Yeah, they are slightly annoying. Not too difficult to clean them up every now and again, though :P

 

Also... Today I did some testing, and transferring mobs via end portals don't work anymore. They disappear into the portal, but they don't appear anywhere in the end. I'm assuming they appear in one of the test worlds instead. Same with the exit portal!

 

Interestingly, mobs will also go through nether portals, but not into our nether. Again, assuming the test world's nether. :)


  • 0
There used to be something here..


#16 srm86

srm86
  • PipPipPipPipPipPipPipPipPipPipPipPip
  • Admin
  • SixtyGig Admin

  • 1,557 posts
  • LocationTexas

Posted 13 August 2015 - 01:04 PM

 

 

Alright. Well, in that case I won't try to disable pigmen from spawning from them. If it's not a bother for anybody else, that is. I just remember going from SG_Wilds to SG_Main a week or two ago and there was just an absolute mess of them and that bugged me!

Yeah, they are slightly annoying. Not too difficult to clean them up every now and again, though :P

 

Also... Today I did some testing, and transferring mobs via end portals don't work anymore. They disappear into the portal, but they don't appear anywhere in the end. I'm assuming they appear in one of the test worlds instead. Same with the exit portal!

 

Interestingly, mobs will also go through nether portals, but not into our nether. Again, assuming the test world's nether. :)

 

Are these the nether portals defined in the main map or are these self-made nether portals?


  • 0


#17 Blue_Dragon360

Blue_Dragon360
  • PipPipPipPipPipPipPipPipPipPip
  • Seasoned
  • Stone Pickaxe

  • 1,028 posts
  • LocationValhalla
  • Nationality:American

Posted 13 August 2015 - 01:15 PM

Are these the nether portals defined in the main map or are these self-made nether portals?

Both


  • 0
There used to be something here..


#18 srm86

srm86
  • PipPipPipPipPipPipPipPipPipPipPipPip
  • Admin
  • SixtyGig Admin

  • 1,557 posts
  • LocationTexas

Posted 16 August 2015 - 08:34 PM

Alright guys. I've been working on the server today, as you probably  noticed by the inventory kerfluffle. Here's what I was able to take care of today:
Gates can be 2- and 3- blocks wide
Set up Main Map portals
Dynmap - sign text will only show on hover (before it showed always)
Fix Dynmap world list so that worlds display in correct order and hidden worlds are not shown
Disable cave layer on DynMap
Dynmap - show actual size of map rather than 7500 in each direction.
 
I wasn't able to replicate the issue with Dynmap updating too slowly, however.
 
It looks like the mob issue with the portals is going to take a little bit more work then I thought. What's happening is that somewhere in one of our plugins "world" is set to default. So when mobs are pushed through the portal, they are going to the primary "world_nether" instead of "SixtyGig_nether". To fix this, I attempted to delete world_nether, world and world_theend. In trying to do that, I found that playerdata is being stored in "world" (it should be stored in "SixtyGig") and that's why it keeps regenerating. Until I can figure out how to stop playerdata from being saved to "world", I won't be able to fix this problem.
 
That said, I am working on it. And, as always, please let me know if there's anything else that needs addressed so I can add it to the list.

  • 0


#19 Sivcere

Sivcere
  • PipPipPipPipPipPip
  • Established
  • Coal

  • 668 posts
  • LocationNew Zealand
  • Nationality:Kiwi as bro

Posted 16 August 2015 - 11:12 PM

 

Alright guys. I've been working on the server today, as you probably  noticed by the inventory kerfluffle. Here's what I was able to take care of today:
Gates can be 2- and 3- blocks wide
Set up Main Map portals
Dynmap - sign text will only show on hover (before it showed always)
Fix Dynmap world list so that worlds display in correct order and hidden worlds are not shown
Disable cave layer on DynMap
Dynmap - show actual size of map rather than 7500 in each direction.
 
I wasn't able to replicate the issue with Dynmap updating too slowly, however.
 
It looks like the mob issue with the portals is going to take a little bit more work then I thought. What's happening is that somewhere in one of our plugins "world" is set to default. So when mobs are pushed through the portal, they are going to the primary "world_nether" instead of "SixtyGig_nether". To fix this, I attempted to delete world_nether, world and world_theend. In trying to do that, I found that playerdata is being stored in "world" (it should be stored in "SixtyGig") and that's why it keeps regenerating. Until I can figure out how to stop playerdata from being saved to "world", I won't be able to fix this problem.
 
That said, I am working on it. And, as always, please let me know if there's anything else that needs addressed so I can add it to the list.

 

^=Black Magic Thanks you two! 


  • 0
I'm a cat now, how odd.


#20 Likliksnek

Likliksnek
  • PipPip
  • Established
  • Plank

  • 252 posts
  • LocationHamburg, Germany
  • Nationality:German

Posted 16 August 2015 - 11:23 PM

Hi Stacy,

 

thank you again for all your work! :)

 

Dynmap signs and world list are fine now, although the mapsize still seems to be the 15000 block wide one. I deleted my cache, just in case, but it comes up as that again regardless. Maybe its just the slow updating again tho and we have to wait a little longer.

 

Regarding the storage folder issue, this sounded a tiny bit like your problem. Maybe its all about the order you do things in?

 

hugs

Lik


  • 0





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users